Email delivery issue
Incident Report for SpotMe
Resolved
Situation has now gone back to normal, the teams have identified the root cause and have applied adequate measures.
Although the issue is resolved, if you encounter any issues regarding email delivery, please contact SpotMe support.
Posted Dec 07, 2023 - 22:58 CET
Investigating
We are currently experiencing difficulties with email delivery.
Our team is actively investigating the root cause of the problem.
Outgoing emails may be delayed or fail to send.
Posted Dec 07, 2023 - 21:18 CET